blob: 34896153c2cd6c6411d85bad1f376ee6d08c8a40 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b"
6
7SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
Patrick Williams8dd68482022-10-04 07:57:18 -05008SRCREV = "a33701196adfad74917046096bf5a2aa0ab0bb50"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
16
17BBCLASSEXTEND = "native nativesdk"