blob: 28c835aebb599b7859d6b459bb88ad8581021b7d [file] [log] [blame]
Vijay Khemka4809bd12019-12-16 17:48:02 -08001SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5
6SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
Andrew Geissler8defc8b2021-12-13 03:41:13 +00007SRCREV = "c4440ebefb36d4c2eebd3d0bdf0ce4671f04a158"
Vijay Khemka4809bd12019-12-16 17:48:02 -08008
9S = "${WORKDIR}/git"
10
11PV = "1.0+git${SRCPV}"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16inherit cmake pkgconfig systemd
17
Kumar Thangavel27cb8232020-09-01 23:05:19 +053018
19def get_service(d):
20 if(d.getVar('OBMC_HOST_INSTANCES') == '0'):
21 return "xyz.openbmc_project.State.Boot.PostCode.service"
22 else:
23 return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
24
Patrick Williams12fc9392021-08-06 09:16:53 -050025SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
Vijay Khemka4809bd12019-12-16 17:48:02 -080026
27DEPENDS += " \
28 sdbusplus \
29 phosphor-dbus-interfaces \
30 phosphor-logging \
31 "
Kumar Thangavel27cb8232020-09-01 23:05:19 +053032
Patrick Williams12fc9392021-08-06 09:16:53 -050033FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
34FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"