blob: 334420c02cadb2f08a5ff2e57213302119b66e64 [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit systemd
7inherit autotools pkgconfig
8
9HOMEPAGE = "https://github.com/openbmc/libmctp"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
12SRC_URI = "git://github.com/openbmc/libmctp \
13 file://default"
Andrew Geissler562f9f62021-06-22 12:51:00 +000014SRCREV = "34d4c96fcf9691e060d8a7f56633bf196c82a52f"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080015
16DEPENDS += "autoconf-archive-native \
17 systemd \
18 "
19
20SYSTEMD_SERVICE_${PN} = "mctp-demux.service"
21
Andrew Jefferyd957f032021-05-12 22:31:34 +093022PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
23PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
24 --without-systemdsystemunitdir,systemd"
25
Andrew Jeffery8e0e67f2021-05-11 13:40:40 +093026PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
27
Andrew Jefferyd957f032021-05-12 22:31:34 +093028CONFFILES_${PN} = "${sysconfdir}/default/mctp"
29
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080030do_install_append() {
31 install -d ${D}${sysconfdir}/default
32 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
33}
34
35S = "${WORKDIR}/git"