blob: 202caa546e95e0d8e842c19212c61c971403ba93 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001require optee-os_3.20.0.bb
2
3SUMMARY = "OP-TEE Trusted OS TA devkit"
4DESCRIPTION = "OP-TEE TA devkit for build TAs"
5HOMEPAGE = "https://www.op-tee.org/"
6
7DEPENDS += "python3-pycryptodome-native"
8
9do_install() {
10 #install TA devkit
11 install -d ${D}${includedir}/optee/export-user_ta/
12 for f in ${B}/export-ta_${OPTEE_ARCH}/* ; do
13 cp -aR $f ${D}${includedir}/optee/export-user_ta/
14 done
15}
16
17do_deploy() {
18 echo "Do not inherit do_deploy from optee-os."
19}
20
21FILES:${PN} = "${includedir}/optee/"
22
23# Build paths are currently embedded
24INSANE_SKIP:${PN}-dev += "buildpaths"