blob: e0e4a59d242f8b6542c015fdc014b53c76f80748 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "PolicyKit-gnome provides an Authentication Agent for PolicyKit"
2HOMEPAGE = "https://gitlab.gnome.org/Archive/policykit-gnome"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=74579fab173e4c5e12aac0cd83ee98ec"
5
6DEPENDS = "glib-2.0-native glib-2.0 gtk+3 polkit intltool-native"
7
8inherit autotools pkgconfig features_check
9
10REQUIRED_DISTRO_FEATURES = "polkit"
11
12SRC_URI = " \
13 git://gitlab.gnome.org/Archive/policykit-gnome.git;protocol=https;branch=master \
14 file://0001-Select-the-current-user-to-authenticate-with-by-defa.patch \
15 file://0002-Auth-dialog-Make-the-label-wrap-at-70-chars.patch \
16 file://0003-Get-user-icon-from-accountsservice-instead-of-lookin.patch \
17 file://0004-Use-fresh-X11-timestamps-when-displaying-authenticat.patch \
18 file://0005-configure.ac-disable-gnome-tools-that-are-not-provid.patch \
19 file://polkit-gnome-authentication-agent-1.desktop \
20"
21SRCREV = "a0763a246a81188f60b0f9810143e49224dc752f"
22S = "${WORKDIR}/git"
23
24
25do_install:append() {
26 install -d ${D}${datadir}/applications
27 install -m644 ${WORKDIR}/polkit-gnome-authentication-agent-1.desktop \
28 ${D}${datadir}/applications
29}