blob: d093697c139a3995abedf6746a5d12ebe071915f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Tracker miners and metadata extractors"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 intltool-native \
10 tracker \
11 zlib \
12"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gsettings gobject-introspection vala bash-completion features_check
17
18SRC_URI += "file://0001-meson.build-Just-warn-if-we-build-without-libseccomp.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050019 file://0001-Set-header-file-to-a-fixed-path-instead-of-a-host-pa.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060020 "
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021SRC_URI[archive.sha256sum] = "17966603dc432a98526b490586a48acd7f9f59935f7895dfc51729a46a6901a3"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23# gobject-introspection is mandatory and cannot be configured
24REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
25GIR_MESON_OPTION = ""
26
27PACKAGECONFIG ??= " \
28 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg", "", d)} \
29 gexiv2 \
30 gstreamer \
31 icu \
32 libexif \
33 libgsf \
34 jpeg \
35 pdf \
36 png \
37 tiff \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050038 raw \
Andrew Geissler517393d2023-01-13 08:55:19 -060039 xml \
40 ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)} \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050041 battery \
42 networkmanager \
Andrew Geissler517393d2023-01-13 08:55:19 -060043"
44
45PACKAGECONFIG[battery] = "-Dbattery_detection=upower,-Dbattery_detection=none,upower"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050046PACKAGECONFIG[cue] = "-Dcue=enabled,-Dcue=disabled,libcue"
47PACKAGECONFIG[ffmpeg] = "-Dgeneric_media_extractor=libav,,ffmpeg"
Andrew Geissler517393d2023-01-13 08:55:19 -060048PACKAGECONFIG[gexiv2] = ",,gexiv2"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050049PACKAGECONFIG[gstreamer] = "-Dgeneric_media_extractor=gstreamer,,gstreamer1.0 gstreamer1.0-plugins-base"
50PACKAGECONFIG[gupnp] = "-Dgstreamer_backend=gupnp,,gupnp-dlna"
Andrew Geissler517393d2023-01-13 08:55:19 -060051PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050052PACKAGECONFIG[icu] = "-Dcharset_detection=icu,,icu"
53PACKAGECONFIG[iso] = "-Diso=enabled,-Diso=disabled,libosinfo"
Andrew Geissler517393d2023-01-13 08:55:19 -060054PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
55PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif"
56PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf"
57PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler"
58PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng"
59PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050060PACKAGECONFIG[raw] = "-Draw=enabled,-Draw=disabled,libraw"
Andrew Geissler517393d2023-01-13 08:55:19 -060061PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050062PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanager"
Andrew Geissler517393d2023-01-13 08:55:19 -060063
64# For security reasons it is strongly recommended to set add meta-security in
65# your layers and 'libseccomp' to PACKAGECONFIG".
66PACKAGECONFIG[seccomp] = "-Dseccomp=true,-Dseccomp=false,libseccomp"
67# not yet in meta-gnome
68PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss"
69
70EXTRA_OEMESON += " \
71 -Dman=false \
72 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
73 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
74"
75
76FILES:${PN} += " \
77 ${datadir}/dbus-1 \
78 ${datadir}/tracker3-miners \
79 ${libdir}/tracker-miners-3.0 \
80 ${systemd_user_unitdir} \
81"