blob: 56595e76865cd32994969f967102cb0295279755 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Multimedia processing server for Linux"
2DESCRIPTION = "Linux server for handling and routing audio and video streams between applications and multimedia I/O devices"
3HOMEPAGE = "https://pipewire.org/"
4BUGTRACKER = "https://gitlab.freedesktop.org/pipewire/pipewire/issues"
5AUTHOR = "Wim Taymans <wtaymans@redhat.com>"
6SECTION = "multimedia"
7
8LICENSE = "MIT & LGPL-2.1-or-later & GPL-2.0-only"
9LIC_FILES_CHKSUM = " \
10 file://LICENSE;md5=2158739e172e58dc9ab1bdd2d6ec9c72 \
11 file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \
12"
13
14DEPENDS = "dbus ncurses"
15
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016SRCREV = "9f7d60c1e84cc0481afc3f6ccf76e127567943a8"
Andrew Geissler517393d2023-01-13 08:55:19 -060017SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
18
19S = "${WORKDIR}/git"
20
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021inherit meson pkgconfig systemd gettext useradd
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23USERADD_PACKAGES = "${PN}"
24
25GROUPADD_PARAM:${PN} = "--system pipewire"
26
27USERADD_PARAM:${PN} = "--system --home / --no-create-home \
28 --comment 'PipeWire multimedia daemon' \
29 --gid pipewire --groups audio,video \
30 pipewire"
31
32SYSTEMD_PACKAGES = "${PN}"
33
34# For "EVL", look up https://evlproject.org/ . It involves
35# a specially prepared kernel, and is currently unavailable
36# in Yocto.
37#
38# Vulkan support is currently (as of version 0.3.44) not functional.
39#
40# manpage generation requires xmltoman, which is not available.
41#
42# The session-managers list specifies which session managers Meson
43# shall download (via git clone) and build as subprojects. In OE,
44# this is not how a session manager should be built. Instead, they
45# should be integrated as separate OE recipes. To prevent PipeWire
46# from using this Meson feature, set an empty list.
47# This does not disable support or the need for session managers,
48# it just prevents this subproject feature.
49#
50# AptX and LDAC are not available in OE. Currently, neither
51# are lv2 and ROC.
52#
53# The RTKit module is deprecated in favor of the newer RT module.
54# It still exists for legacy setups that still include it in
55# their PipeWire configuration files.
56EXTRA_OEMESON += " \
57 -Devl=disabled \
58 -Dtests=disabled \
59 -Dudevrulesdir=${nonarch_base_libdir}/udev/rules.d/ \
60 -Dsystemd-system-unit-dir=${systemd_system_unitdir} \
61 -Dsystemd-user-unit-dir=${systemd_user_unitdir} \
62 -Dman=disabled \
63 -Dsession-managers='[]' \
64 -Dlv2=disabled \
65 -Droc=disabled \
66 -Dbluez5-codec-aptx=disabled \
67 -Dbluez5-codec-ldac=disabled \
68 -Dlegacy-rtkit=false \
69"
70
71# spa alsa plugin code uses typedef redefinition, which is officially a C11 feature.
72# Pipewire builds with 'c_std=gnu99' by default. Recent versions of gcc don't issue this warning in gnu99
73# mode but it looks like clang still does
74CFLAGS:append = " -Wno-typedef-redefinition"
75
76# According to wireplumber documentation only one session manager should be installed at a time
77# Possible options are media-session, which has fewer dependencies but is very simple,
78# or wireplumber, which is more powerful.
79PIPEWIRE_SESSION_MANAGER ??= "wireplumber"
80
81FFMPEG_AVAILABLE = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'ffmpeg', '', d)}"
82BLUETOOTH_AAC = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'bluez-aac', '', d)}"
83
84PACKAGECONFIG:class-target ??= " \
85 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
86 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez bluez-opus ${BLUETOOTH_AAC}', '', d)} \
87 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service systemd-user-service', '', d)} \
Andrew Geissler517393d2023-01-13 08:55:19 -060088 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa vulkan pulseaudio', d)} \
89 ${PIPEWIRE_SESSION_MANAGER} \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060090 ${FFMPEG_AVAILABLE} avahi flatpak gstreamer gsettings jack libusb pw-cat raop sndfile v4l2 udev volume webrtc-echo-cancelling libcamera \
Andrew Geissler517393d2023-01-13 08:55:19 -060091"
92
93# "jack" and "pipewire-jack" packageconfigs cannot be both enabled,
94# since "jack" imports libjack, and "pipewire-jack" generates
95# libjack.so* files, thus colliding with the libpack package. This
96# is why these two are marked in their respective packageconfigs
97# as being in conflict.
98PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa pipewire-alsa-card-profile"
99PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi"
100PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc"
101PACKAGECONFIG[bluez-aac] = "-Dbluez5-codec-aac=enabled,-Dbluez5-codec-aac=disabled,fdk-aac"
102PACKAGECONFIG[bluez-opus] = "-Dbluez5-codec-opus=enabled,-Dbluez5-codec-opus=disabled,libopus"
103PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native graphviz-native"
104PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg"
105PACKAGECONFIG[flatpak] = "-Dflatpak=enabled,-Dflatpak=disabled,glib-2.0"
106PACKAGECONFIG[gsettings] = "-Dgsettings=enabled,-Dgsettings=disabled,glib-2.0"
107PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base,,gstreamer1.0-pipewire"
108PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack,,,pipewire-jack"
109PACKAGECONFIG[libcamera] = "-Dlibcamera=enabled,-Dlibcamera=disabled,libcamera libdrm"
110PACKAGECONFIG[libcanberra] = "-Dlibcanberra=enabled,-Dlibcanberra=disabled,libcanberra"
111PACKAGECONFIG[libusb] = "-Dlibusb=enabled,-Dlibusb=disabled,libusb"
112PACKAGECONFIG[media-session] = ",,,pipewire-media-session,,wireplumber"
113PACKAGECONFIG[pulseaudio] = "-Dlibpulse=enabled,-Dlibpulse=disabled,pulseaudio,,pipewire-pulse"
114PACKAGECONFIG[pipewire-alsa] = "-Dpipewire-alsa=enabled,-Dpipewire-alsa=disabled,alsa-lib"
115PACKAGECONFIG[pipewire-jack] = "-Dpipewire-jack=enabled -Dlibjack-path=${libdir}/${PW_MODULE_SUBDIR}/jack,-Dpipewire-jack=disabled,jack,,pipewire-jack,jack"
116PACKAGECONFIG[pw-cat] = "-Dpw-cat=enabled,-Dpw-cat=disabled"
117PACKAGECONFIG[raop] = "-Draop=enabled,-Draop=disabled,openssl"
118PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2"
119PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
120PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
121PACKAGECONFIG[systemd-system-service] = "-Dsystemd-system-service=enabled,-Dsystemd-system-service=disabled,systemd"
122# "systemd-user-service" packageconfig will only install service
123# files to rootfs but not enable them as systemd.bbclass
124# currently lacks the feature of enabling user services.
125PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=enabled,-Dsystemd-user-service=disabled,systemd"
126# pw-cat needs sndfile packageconfig to be enabled
127PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev"
128PACKAGECONFIG[v4l2] = "-Dv4l2=enabled,-Dv4l2=disabled,udev"
129PACKAGECONFIG[volume] = "-Dvolume=enabled,-Dvolume=disabled"
130PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-headers vulkan-loader"
131PACKAGECONFIG[webrtc-echo-cancelling] = "-Decho-cancel-webrtc=enabled,-Decho-cancel-webrtc=disabled,webrtc-audio-processing"
132PACKAGECONFIG[wireplumber] = ",,,wireplumber,,media-session"
133
134PACKAGESPLITFUNCS:prepend = " split_dynamic_packages "
135PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends "
136
137SPA_SUBDIR = "spa-0.2"
138PW_MODULE_SUBDIR = "pipewire-0.3"
139
140remove_unused_installed_files() {
141 # jack.conf is used by pipewire-jack (not the JACK SPA plugin).
142 # Remove it if pipewire-jack is not built to avoid creating the
143 # pipewire-jack package.
144 if ${@bb.utils.contains('PACKAGECONFIG', 'pipewire-jack', 'false', 'true', d)}; then
145 rm -f "${D}${datadir}/pipewire/jack.conf"
146 fi
147
148 # minimal.conf is an example of how to minimally configure the
149 # daemon and is not meant to be used for production.
150 rm -f "${D}${datadir}/pipewire/minimal.conf"
151}
152
153do_install[postfuncs] += "remove_unused_installed_files"
154
155python split_dynamic_packages () {
156 # Create packages for each SPA plugin. These plugins are located
157 # in individual subdirectories, so a recursive search is needed.
158 spa_libdir = d.expand('${libdir}/${SPA_SUBDIR}')
159 do_split_packages(d, spa_libdir, r'^libspa-(.*)\.so$', d.expand('${PN}-spa-plugins-%s'), 'PipeWire SPA plugin for %s', extra_depends='', recursive=True)
160
161 # Create packages for each PipeWire module.
162 pw_module_libdir = d.expand('${libdir}/${PW_MODULE_SUBDIR}')
163 do_split_packages(d, pw_module_libdir, r'^libpipewire-module-(.*)\.so$', d.expand('${PN}-modules-%s'), 'PipeWire %s module', extra_depends='', recursive=False)
164}
165
166python set_dynamic_metapkg_rdepends () {
167 import os
168 import oe.utils
169
Patrick Williams864cc432023-02-09 14:54:44 -0600170 if bb.data.inherits_class('nativesdk', d) or bb.data.inherits_class('native', d):
171 return
172
Andrew Geissler517393d2023-01-13 08:55:19 -0600173 # Go through all generated SPA plugin and PipeWire module packages
174 # (excluding the main package and the -meta package itself) and
175 # add them to the -meta package as RDEPENDS.
176
177 base_pn = d.getVar('PN')
178
179 spa_pn = base_pn + '-spa-plugins'
180 spa_metapkg = spa_pn + '-meta'
181
182 pw_module_pn = base_pn + '-modules'
183 pw_module_metapkg = pw_module_pn + '-meta'
184
185 d.setVar('ALLOW_EMPTY:' + spa_metapkg, "1")
186 d.setVar('FILES:' + spa_metapkg, "")
187
188 d.setVar('ALLOW_EMPTY:' + pw_module_metapkg, "1")
189 d.setVar('FILES:' + pw_module_metapkg, "")
190
191 blacklist = [ spa_pn, spa_metapkg, pw_module_pn, pw_module_metapkg ]
192 spa_metapkg_rdepends = []
193 pw_module_metapkg_rdepends = []
194 pkgdest = d.getVar('PKGDEST')
195
196 for pkg in oe.utils.packages_filter_out_system(d):
197 if pkg in blacklist:
198 continue
199
200 is_spa_pkg = pkg.startswith(spa_pn)
201 is_pw_module_pkg = pkg.startswith(pw_module_pn)
202 if not is_spa_pkg and not is_pw_module_pkg:
203 continue
204
205 if pkg in spa_metapkg_rdepends or pkg in pw_module_metapkg_rdepends:
206 continue
207
208 # See if the package is empty by looking at the contents of its
209 # PKGDEST subdirectory. If this subdirectory is empty, then then
210 # package is empty as well. Empty packages do not get added to
211 # the meta package's RDEPENDS.
212 pkgdir = os.path.join(pkgdest, pkg)
213 if os.path.exists(pkgdir):
214 dir_contents = os.listdir(pkgdir) or []
215 else:
216 dir_contents = []
217 is_empty = len(dir_contents) == 0
218 if not is_empty:
219 if is_spa_pkg:
220 spa_metapkg_rdepends.append(pkg)
221 if is_pw_module_pkg:
222 pw_module_metapkg_rdepends.append(pkg)
223
224 d.setVar('RDEPENDS:' + spa_metapkg, ' '.join(spa_metapkg_rdepends))
225 d.setVar('DESCRIPTION:' + spa_metapkg, spa_pn + ' meta package')
226
227 d.setVar('RDEPENDS:' + pw_module_metapkg, ' '.join(pw_module_metapkg_rdepends))
228 d.setVar('DESCRIPTION:' + pw_module_metapkg, pw_module_pn + ' meta package')
229}
230
231PACKAGES =+ "\
232 libpipewire \
233 ${PN}-tools \
234 ${PN}-pulse \
235 ${PN}-alsa \
236 ${PN}-jack \
237 ${PN}-spa-plugins \
238 ${PN}-spa-plugins-meta \
239 ${PN}-spa-tools \
240 ${PN}-modules \
241 ${PN}-modules-meta \
242 ${PN}-alsa-card-profile \
243 ${PN}-v4l2 \
244 gstreamer1.0-pipewire \
245"
246
247PACKAGES_DYNAMIC = "^${PN}-spa-plugins.* ^${PN}-modules.*"
Patrick Williams864cc432023-02-09 14:54:44 -0600248PACKAGES_DYNAMIC:class-native = ""
Andrew Geissler517393d2023-01-13 08:55:19 -0600249
250SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd-system-service', 'pipewire.service', '', d)}"
251CONFFILES:${PN} += "${datadir}/pipewire/pipewire.conf"
252FILES:${PN} = " \
253 ${datadir}/pipewire \
254 ${systemd_system_unitdir}/pipewire* \
255 ${systemd_user_unitdir} \
256 ${bindir}/pipewire \
257 ${bindir}/pipewire-avb \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600258 ${bindir}/pipewire-aes67 \
259 ${sysconfdir}/security/limits.d \
Andrew Geissler517393d2023-01-13 08:55:19 -0600260"
261
262RRECOMMENDS:${PN}:class-target += " \
263 pipewire-modules-meta \
264 pipewire-spa-plugins-meta \
265"
266
267FILES:${PN}-dev += " \
268 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so \
269"
270
271CONFFILES:libpipewire += "${datadir}/pipewire/client.conf"
272FILES:libpipewire = " \
273 ${datadir}/pipewire/client.conf \
274 ${libdir}/libpipewire-*.so.* \
275"
276# Add the bare minimum modules and plugins required to be able
277# to use libpipewire. Without these, it is essentially unusable.
278RDEPENDS:libpipewire += " \
279 ${PN}-modules-client-node \
280 ${PN}-modules-protocol-native \
281 ${PN}-spa-plugins-support \
282"
283
284FILES:${PN}-tools = " \
285 ${bindir}/pw-cat \
286 ${bindir}/pw-cli \
Patrick Williams8e7b46e2023-05-01 14:19:06 -0500287 ${bindir}/pw-config \
Andrew Geissler517393d2023-01-13 08:55:19 -0600288 ${bindir}/pw-dot \
289 ${bindir}/pw-dsdplay \
290 ${bindir}/pw-dump \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500291 ${bindir}/pw-encplay \
Andrew Geissler517393d2023-01-13 08:55:19 -0600292 ${bindir}/pw-link \
293 ${bindir}/pw-loopback \
294 ${bindir}/pw-metadata \
295 ${bindir}/pw-mididump \
296 ${bindir}/pw-midiplay \
297 ${bindir}/pw-midirecord \
298 ${bindir}/pw-mon \
299 ${bindir}/pw-play \
300 ${bindir}/pw-profiler \
301 ${bindir}/pw-record \
302 ${bindir}/pw-reserve \
303 ${bindir}/pw-top \
304"
305
306# This is a shim daemon that is intended to be used as a
307# drop-in PulseAudio replacement, providing a pulseaudio-compatible
308# socket that can be used by applications that use libpulse.
309CONFFILES:${PN}-pulse += "${datadir}/pipewire/pipewire-pulse.conf"
310FILES:${PN}-pulse = " \
311 ${datadir}/pipewire/pipewire-pulse.conf \
312 ${systemd_system_unitdir}/pipewire-pulse.* \
313 ${systemd_user_unitdir}/pipewire-pulse.* \
314 ${bindir}/pipewire-pulse \
315"
316RDEPENDS:${PN}-pulse += " \
317 ${PN}-modules-protocol-pulse \
318"
319
320# ALSA plugin to redirect audio to pipewire.
321FILES:${PN}-alsa = "\
322 ${libdir}/alsa-lib/* \
323 ${datadir}/alsa/alsa.conf.d/* \
324"
325
326# JACK drop-in libraries to redirect audio to pipewire.
327CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf"
328FILES:${PN}-jack = "\
329 ${bindir}/pw-jack \
330 ${datadir}/pipewire/jack.conf \
331 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \
332"
333
334# Dynamic SPA plugin packages (see set_dynamic_metapkg_rdepends).
335FILES:${PN}-spa-plugins = ""
336RRECOMMENDS:${PN}-spa-plugins += "${PN}-spa-plugins-meta"
337
338FILES:${PN}-spa-plugins-bluez5 += " \
339 ${datadir}/${SPA_SUBDIR}/bluez5/* \
340"
341
342FILES:${PN}-spa-tools = " \
343 ${bindir}/spa-* \
344"
345
346# Dynamic PipeWire module packages (see set_dynamic_metapkg_rdepends).
347FILES:${PN}-modules = ""
348RRECOMMENDS:${PN}-modules += "${PN}-modules-meta"
349
350CONFFILES:${PN}-modules-rt = "${datadir}/pipewire/client-rt.conf"
351FILES:${PN}-modules-rt += " \
352 ${datadir}/pipewire/client-rt.conf \
353 "
354
355CONFFILES:${PN}-modules-filter-chain = "${datadir}/pipewire/filter-chain/*"
356FILES:${PN}-modules-filter-chain += " \
357 ${datadir}/pipewire/filter-chain/* \
358"
359
360FILES:${PN}-alsa-card-profile = " \
361 ${datadir}/alsa-card-profile/* \
362 ${nonarch_base_libdir}/udev/rules.d/90-pipewire-alsa.rules \
363"
364
365# V4L2 interface emulator for sending/receiving data between PipeWire and V4L2 applications.
366FILES:${PN}-v4l2 += " \
367 ${bindir}/pw-v4l2 \
368 ${libdir}/${PW_MODULE_SUBDIR}/v4l2/libpw-v4l2.so \
369"
370
371FILES:gstreamer1.0-pipewire = " \
372 ${libdir}/gstreamer-1.0/* \
373"
374
375BBCLASSEXTEND = "native nativesdk"