blob: 38389276f2a17843ff0d0ec1f0771c1066f5b0ae [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "This provides screenshot/screencast xdg-desktop-portal backends for wlroots."
2HOMEPAGE = "https://github.com/emersion/xdg-desktop-portal-wlr"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e316e9609dd7672b87ff25b46b2cf3e1"
5
6DEPENDS = " \
7 wayland \
8 wayland-native \
9 wayland-protocols \
10 libdrm \
11 libinih \
12 pipewire \
13 virtual/libgbm \
14"
15
16inherit meson pkgconfig features_check
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017REQUIRED_DISTRO_FEATURES = "opengl wayland"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19SRC_URI = "git://github.com/emersion/xdg-desktop-portal-wlr.git;protocol=https;nobranch=1"
20
21S = "${WORKDIR}/git"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050022SRCREV = "6737c209578e7f17536dbcb8fb2169dcf86ce528"
Andrew Geissler517393d2023-01-13 08:55:19 -060023
24PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'basu', d)}"
25
26PACKAGECONFIG[man-pages] = "-Dman-pages=enabled,-Dman-pages=disabled,scdoc-native"
27PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsd-bus-provider=libsystemd,-Dsystemd=disabled"
28PACKAGECONFIG[basu] = "-Dsd-bus-provider=basu,,basu"
29
30FILES:${PN} += "${systemd_user_unitdir} ${datadir}"