blob: 6578bcfeb78dfe20dea69232675efacd994d6206 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-2.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008 file://LICENSE;md5=fd3b896dadaeec3410d753ffaeadcfac \
Andrew Geissler517393d2023-01-13 08:55:19 -06009 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
10 file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
Andrew Geissler517393d2023-01-13 08:55:19 -060011"
12
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=https;branch=master"
Andrew Geissler517393d2023-01-13 08:55:19 -060014
15SRCREV = "4157a27d39f1dd5b95750ecb6acd1481432785d8"
16
17DEPENDS = "openssl"
18
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23do_configure:prepend() {
24 sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt
25}
26
27do_install:append() {
28 # paho-mqtt installes some thing that we don't want.
29 rm -rf ${D}${prefix}/samples
30 find ${D}${prefix} -maxdepth 1 -type f -delete
31}
32
33EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON"