blob: 2e06b701cc4496144a5499ac7d3886193a2603c3 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "A header only library for creating and validating json web tokens in c++"
2HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
6
7SRC_URI = "git://github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
8 "
9
10SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
11
12S = "${WORKDIR}/git"
13
14DEPENDS = "openssl"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF -DJWT_CMAKE_FILES_INSTALL_DIR=${libdir}/cmake"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050019
20BBCLASSEXTEND = "nativesdk"