blob: ff4e1f0563a3000e5d3c028794d99ed8dc9ffe19 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Perl interface to the PC/SC smart card library"
2DESCRIPTION = "Perl wrapper to the PC/SC smartcard library (pcsc-lite) \
3together with some small examples. \
4The provided modules are Chipcard::PCSC and Chipcard::PCSC::Card."
5HOMEPAGE = "https://metacpan.org/dist/pcsc-perl"
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10SRC_URI = "https://cpan.metacpan.org/authors/id/W/WH/WHOM/pcsc-perl-${PV}.tar.bz2"
11SRC_URI[md5sum] = "45601505dbb7b27329811ac9bad35fab"
12SRC_URI[sha256sum] = "2722b7e5543e4faf3ba1ec6b29a7dfec6d92be1edec09d0a3191992d4d88c69d"
13
14S = "${WORKDIR}/pcsc-perl-${PV}"
15
16inherit cpan pkgconfig
17
18DEPENDS += "pcsc-lite"
19
20RDEPENDS:${PN} += "perl-module-carp"
21
22BBCLASSEXTEND="native"