blob: 3a9943916e463e4dd79482d0eac242fdd51718c4 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Bitwise terminal calculator"
2DESCRIPTION = "Bitwise is multi base interactive calculator \
3supporting dynamic base conversion and bit manipulation.\
4It's a handy tool for low level hackers, \
5kernel developers and device drivers developers."
6
7HOMEPAGE = "https://github.com/mellowcandle/bitwise"
8SECTION = "console/utils"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
12
13SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
14 file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015 file://run-ptest \
16 file://ptest.out.expected \
Andrew Geissler595f6302022-01-24 19:11:47 +000017 "
18SRC_URI[sha256sum] = "f524f794188a10defc4df673d8cf0b3739f93e58e93aff0cdb8a99fbdcca2ffb"
19
20UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
21
22S = "${WORKDIR}/${BPN}-v${PV}"
23
24DEPENDS = "ncurses readline"
25
Patrick Williams8e7b46e2023-05-01 14:19:06 -050026inherit autotools ptest
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}
30 install -m 0644 ${WORKDIR}/ptest.out.expected ${D}${PTEST_PATH}/ptest.out.expected
31}
32