blob: 92466f67a30f0c8e96deea2a091eb9b444d6e82d [file] [log] [blame]
Patrick Williams975a06f2022-10-21 14:42:47 -05001SUMMARY = "Double conversion libraries"
2DESCRIPTION = "This provides binary-decimal and decimal-binary routines for IEEE doubles."
3HOMEPAGE = "https://github.com/google/double-conversion.git"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1ea35644f0ec0d9767897115667e901f"
7
8
9S = "${WORKDIR}/git"
10
11SRC_URI = " \
12 git://github.com/google/double-conversion.git;protocol=https;branch=master \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013 file://run-ptest \
Patrick Williams975a06f2022-10-21 14:42:47 -050014"
15SRCREV = "af09fd65fcf24eee95dc62813ba9123414635428"
16
Patrick Williams8e7b46e2023-05-01 14:19:06 -050017inherit cmake ptest
Patrick Williams975a06f2022-10-21 14:42:47 -050018
19EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050020
21# These ptest use ctest (provided by cmake)
22RDEPENDS:${PN}-ptest += "cmake"
23# Build tests only if ptest is enabled
24EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTING=ON', '', d)}"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/test
28 cp -rf ${B}/test ${D}${PTEST_PATH}
29 install -m 0644 ${B}/CTestTestfile.cmake ${D}${PTEST_PATH}/
30 files="
31 CTestTestfile.cmake
32 test/CTestTestfile.cmake
33 test/cmake_install.cmake
34 test/cctest/CTestTestfile.cmake
35 test/cctest/cmake_install.cmake
36 "
37 for file in $files; do
38 sed -i -e "s|${B}|${PTEST_PATH}|g" -e "s|${S}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" "${D}${PTEST_PATH}/${file}"
39 done
40
41}