blob: 8d61b7f7bcb0753ed945cd77cb7ce1f09fe32c6e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
2HOMEPAGE = "http://homepage.boetes.org/software/mg/"
3LICENSE = "PD"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05004LIC_FILES_CHKSUM = "file://version.c;md5=36d8ace99e6cd003132975a9266d3f77"
Andrew Geissler517393d2023-01-13 08:55:19 -06005DEPENDS = "ncurses libbsd"
6SECTION = "console/editors"
7
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008SRCREV = "4e6d2de9582cfe7f0977be4ce9532e3d33c5be15"
Andrew Geissler517393d2023-01-13 08:55:19 -06009SRC_URI = "git://github.com/hboetes/mg;branch=master;protocol=https \
10 file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \
11 file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \
12 "
13SRC_URI:append:libc-musl = "\
14 file://0001-Undefine-REGEX-for-musl-based-systems.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
20EXTRA_OEMAKE = "\
21 'CC=${CC}' \
22 'LDFLAGS=${LDFLAGS}' \
23 \
24 'prefix=${prefix}' \
25 'bindir=${bindir}' \
26 'libdir=${libdir}' \
27 'includedir=${includedir}' \
28 'mandir=${mandir}' \
29 'PKG_CONFIG=pkg-config' \
30"
31
32CFLAGS += "-I${STAGING_INCDIR}/bsd"
33
34do_install () {
35 oe_runmake install DESTDIR=${D}
36}
37
38inherit pkgconfig