blob: fd4dc42487de865859f8d95af011c116977ec946 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001DESCRIPTION = "Recipe to trigger execution of all meta-python ptest images."
2HOMEPAGE = "https://www.openembedded.org/"
3
4LICENSE = "MIT"
5
6inherit features_check nopackages
7REQUIRED_DISTRO_FEATURES = "ptest"
8
9require conf/include/ptest-packagelists-meta-python.inc
10
11# Include the full set of ptests
12PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON} ${PTESTS_SLOW_META_PYTHON}"
13
14do_testimage[noexec] = "1"
15do_testimage[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PYTHON').split()])}"
16
17do_build[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_build' for x in d.getVar('PTESTS_META_PYTHON').split()])}"
18
19# normally image.bbclass would do this
20EXCLUDE_FROM_WORLD = "1"
21
22python () {
23 if bb.utils.contains('IMAGE_CLASSES', 'testimage', True, False, d):
24 bb.build.addtask("do_testimage", "", "", d)
25}