blob: a649cbb94c32fcc8c24c10419711460fe8abe91c [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require conf/include/ptest-packagelists-meta-python.inc
5
Brad Bishop19323692019-04-05 15:28:33 -04006require meta-python-image-base.bb
7
8SUMMARY = "meta-python ptest test image"
9
Patrick Williams8e7b46e2023-05-01 14:19:06 -050010DESCRIPTION += "Also including the ${MCNAME} ptest package."
11HOMEPAGE = "https://www.openembedded.org/"
12
13PTESTS_META_PYTHON = "${PTESTS_SLOW_META_PYTHON} ${PTESTS_FAST_META_PYTHON}"
14
15IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"
16
17BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS_META_PYTHON').split()])}"
18
19# The image can be sufficiently large (~1.8GB) that we need to be careful that it fits in a live
20# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
21# box) and explicitly add up to 1500MB.
22IMAGE_OVERHEAD_FACTOR = "1.0"
23IMAGE_ROOTFS_EXTRA_SPACE = "324288"
24# If a particular ptest needs more space, it can be customized:
25#IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-<pn> = "1024288"
26
27# ptests need more memory than standard to avoid the OOM killer
28QB_MEM = "-m 1024"
29# If a particular ptest needs more memory, it can be customized:
30#QB_MEM:virtclass-mcextend-<pn> = "-m 4096"
31
32TEST_SUITES = "ping ssh parselogs ptest"
33
34# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
35PTEST_EXPECT_FAILURE = "1"
36
37python () {
38 if not d.getVar("MCNAME"):
39 raise bb.parse.SkipRecipe("No class extension set")
40}
41