blob: 21c36687e263ded2e67ea4bf4fca9e2deb9bf180 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6542fc4ce5904ffb741ef56f8fe33452"
Patrick Williams92b42cb2022-09-03 06:53:57 -05006
7SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05008SRCREV = "1221ef62ff0de15bbeaf79e68e08a65d62c73ff4"
Patrick Williams92b42cb2022-09-03 06:53:57 -05009
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13PIP_INSTALL_PACKAGE = "gcovr"
14
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments ${PYTHON_PN}-multiprocessing"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17BBCLASSEXTEND = "native nativesdk"