blob: 0cfc80ec9d8f3ce63c626c6f7d50f81792ca679d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009SRC_URI[sha256sum] = "a950236df04ad75b5bc7f816f9af3d74dc118fd42f2ff7e80e8e60ca1f182e2d"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11RDEPENDS:${PN} = "\
12 ${PYTHON_PN}-setuptools \
13 ${PYTHON_PN}-jedi \
14 ${PYTHON_PN}-decorator \
15 ${PYTHON_PN}-pickleshare \
16 ${PYTHON_PN}-traitlets \
17 ${PYTHON_PN}-prompt-toolkit \
18 ${PYTHON_PN}-pygments \
19 ${PYTHON_PN}-backcall \
20 ${PYTHON_PN}-pydoc \
21 ${PYTHON_PN}-debugger \
22 ${PYTHON_PN}-pexpect \
23 ${PYTHON_PN}-unixadmin \
24 ${PYTHON_PN}-misc \
25 ${PYTHON_PN}-sqlite3 \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050026 ${PYTHON_PN}-stack-data \
Andrew Geissler517393d2023-01-13 08:55:19 -060027"
28
29inherit setuptools3 pypi