blob: c27d490f4c74769bd542f130164ed01b09957aaf [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
2HOMEPAGE = "https://github.com/balloob/pychromecast"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
5
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006SRC_URI[sha256sum] = "0de98e9e5be43269dd41efb16126ab0d5ba941ca4acae024329712851c0c0324"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8PYPI_PACKAGE = "PyChromecast"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-logging \
14 ${PYTHON_PN}-zeroconf \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-protobuf \
18 ${PYTHON_PN}-compression \
19"