blob: 174545dd2eb7160ccb174c9e4571878efe9714e6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The new Python SDK for Sentry.io"
2DESCRIPTION = "This is the next line of the Python SDK \
3for Sentry, intended to replace the raven package on PyPI."
4HOMEPAGE = "https://github.com/getsentry/sentry-python"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7fcb29c83dd48cb7b112d0dd81111a89"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8RDEPENDS:${PN} += "\
9 ${PYTHON_PN}-urllib3 \
10 ${PYTHON_PN}-core \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-threading \
14 ${PYTHON_PN}-compression \
15 ${PYTHON_PN}-datetime \
16"
17
Patrick Williams8e7b46e2023-05-01 14:19:06 -050018SRC_URI[sha256sum] = "a3410381ae769a436c0852cce140a5e5e49f566a07fb7c2ab445af1302f6ad89"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20PYPI_PACKAGE = "sentry-sdk"
21
22inherit pypi setuptools3