blob: 921dba0631f2cfa2290bb8f5914eda747e1c9819 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "File manager for the Xfce Desktop Environment"
2SECTION = "x11"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "libxml-parser-perl-native exo gdk-pixbuf libxfce4ui libnotify xfce4-panel udev"
6
7inherit xfce gobject-introspection features_check mime-xdg perlnative
8
9# xfce4 depends on libwnck3, gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
10# cairo would at least needed to be built with xlib.
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013SRC_URI[sha256sum] = "c4463ce2fb1d628adce70a828e8b4de5fa0802236894d2c40f749471619bedcc"
Andrew Geissler517393d2023-01-13 08:55:19 -060014
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
16PACKAGECONFIG[pcre] = "--enable-pcre2,--disable-pcre2,libpcre2"
17PACKAGECONFIG[x11] = ",,libsm startup-notification"
18
19FILES:${PN} += " \
20 ${libdir}/thunarx-3/* \
21 ${libdir}/xfce4/panel/plugins/* \
22 ${libdir}/Thunar/[Tt]hunar* \
23 ${systemd_user_unitdir} \
24 ${datadir}/dbus-1 \
25 ${datadir}/metainfo \
26 ${datadir}/polkit-1 \
27 ${datadir}/Thunar \
28 ${datadir}/xfce4/panel/plugins/* \
29"
30
31RRECOMMENDS:${PN} = " \
32 gvfs \
33 gvfsd-trash \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'dbus', 'tumbler', '', d)} \
35"