blob: f7f0ff162b7da43aad996ea38d6e8f2f44d5f382 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "CircuitPython driver for motor, stepper, and servo based on PCA9685."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_PCA9685"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e7eb6b599fb0cfb06485c64cd4242f62"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_PCA9685.git;branch=main;protocol=https"
7SRCREV = "2780c4102f4c23fbab252aa1198b61ba7e2d1b2c"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \
17 python3-adafruit-circuitpython-busdevice \
18 python3-adafruit-circuitpython-register \
19 python3-core \
20"
21COMPATIBLE_HOST:libc-musl:class-target = "null"