blob: 4285d11b72407cc65435994b6936920a1d91dcfb [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Provides API for encoding/decoding of data to/from D-Bus wire format"
2DESCRIPTION = "This crate provides API for encoding/decoding of data to/from D-Bus wire format.\
3This binary wire format is simple and very efficient and hence useful outside of D-Bus context as well.\
4A modified form of this format, GVariant is very commonly used for efficient storage of arbitrary \
5data and is also supported by this crate."
6HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d"
9
10SRC_URI = " \
11 git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \
12 file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \
13"
14
15SRCREV = "07506776fab5f58e029760bb4b288f670c7eecd6"
16S = "${WORKDIR}/zvariant"
17
18python do_clean_lic_file_symlink() {
19 bb.utils.remove("LICENCE")
20}
21
22addtask clean_lic_file_symlink after do_unpack before do_patch
23
24inherit cargo cargo-update-recipe-crates
25
26# Remove this when the recipe is reproducible
27EXCLUDE_FROM_WORLD = "1"
28
29require ${BPN}-crates.inc
30require ${BPN}-git-crates.inc