blob: 10103830af8dc625afad706d435ac80960790973 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Patrick Williams8e7b46e2023-05-01 14:19:06 -05004SUMMARY = "Implementation of fts for musl libc packages"
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "https://github.com/pullmoll/musl-fts"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006DESCRIPTION = "The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc."
Brad Bishop19323692019-04-05 15:28:33 -04007LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5ffe358174aad383f1b69ce3b53da982"
9SECTION = "libs"
10
11SRCREV = "0bde52df588e8969879a2cae51c3a4774ec62472"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/pullmoll/musl-fts.git;branch=master;protocol=https"
Brad Bishop19323692019-04-05 15:28:33 -040014
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18#
19# We will skip parsing for non-musl systems
20#
21COMPATIBLE_HOST = ".*-musl.*"
22