blob: b446fa391d5c44780f1b392dc869874f1d033a71 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "A simple, correct PEP517 package builder"
2HOMEPAGE = "https://github.com/pypa/build"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c"
5
6SRC_URI[sha256sum] = "d5b71264afdb5951d6704482aac78de887c80691c52b88a9ad195983ca2c9269"
7
8inherit pypi python_flit_core
9
10DEPENDS += "python3-pyproject-hooks-native"
11
12DEPENDS:remove:class-native = "python3-build-native"
13
14# Skip dependencies as we're doing a minimal build to bootstrap
15PEP517_BUILD_OPTS:class-native = "--skip-dependency-check"
16
17do_compile:prepend:class-native() {
18 export PYTHONPATH="${S}/src"
19}
20
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021RDEPENDS:${PN} += " \
22 python3-compression \
23 python3-difflib \
24 python3-ensurepip \
25 python3-logging \
26 python3-packaging \
27 python3-pyproject-hooks \
28 python3-tomllib \
29 python3-venv \
30"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060031
32BBCLASSEXTEND = "native nativesdk"