blob: 8ec885fabf24dbeb747e6cccb706bfeee9931433 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016SRC_URI[sha256sum] = "b2c3bbead72189c0bba6e12848b484ceafadb6e872ac31e40013228239366221"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
23 python3-sortedcontainers \
24 python3-statistics \
25 python3-unittest \
26 "
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050030 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060031 "
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/examples
35 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
36 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
37}
38
39BBCLASSEXTEND = "native nativesdk"