blob: fa6d930a9c2cf16a985cd40a20ff15128d3b8dd7 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
Patrick Williamsde0582f2022-04-08 10:23:27 -05002HOMEPAGE = "https://pypi.org/project/Jinja2/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
Andrew Geisslerd5838332022-05-27 11:33:10 -05007SRC_URI[sha256sum] = "31351a702a408a9e7595a8fc6150fc3f43bb6bf7e319770cbc0db9df9437e852"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050015inherit pypi setuptools3 ptest
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17SRC_URI += " \
18 file://run-ptest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN}-ptest += " \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050027 ${PYTHON_PN}-pytest \
28 ${PYTHON_PN}-unittest-automake-output \
29 ${PYTHON_PN}-toml \
30 ${PYTHON_PN}-unixadmin \
Andrew Geissler9aee5002022-03-30 16:27:02 +000031"
32
33RDEPENDS:${PN} += " \
34 ${PYTHON_PN}-asyncio \
35 ${PYTHON_PN}-crypt \
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-json \
38 ${PYTHON_PN}-markupsafe \
39 ${PYTHON_PN}-math \
40 ${PYTHON_PN}-netclient \
41 ${PYTHON_PN}-numbers\
42 ${PYTHON_PN}-pickle \
43 ${PYTHON_PN}-pprint \
44 ${PYTHON_PN}-shell \
45 ${PYTHON_PN}-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"