blob: c0977c74d3049c8e371eb0ca7c003f40077583d3 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
4HOMEPAGE = "https://pypi.org/project/psutil/"
5
Patrick Williams7784c422022-11-17 07:29:11 -06006SRC_URI[sha256sum] = "3d7f9739eb435d4b1338944abe23f49584bde5395f27487d2ee25ad9a8774a62"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8inherit pypi setuptools3
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010PACKAGES =+ "${PN}-tests"
11
12FILES:${PN}-tests += " \
13 ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
14 ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
15"
16
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-threading \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-resource \
25"
26
Patrick Williams8e7b46e2023-05-01 14:19:06 -050027RDEPENDS:${PN}-tests += " \
28 ${PN} \
29 ${PYTHON_PN} \
30 coreutils \
31 procps \
32 binutils \
33 gcc \
34 gcc-symlinks \
35 libstdc++ \
36 libstdc++-dev \
37"
38
39INSANE_SKIP:${PN}-tests += "dev-deps"
40
Andrew Geissler9aee5002022-03-30 16:27:02 +000041BBCLASSEXTEND = "native nativesdk"