blob: 5bd8d32b140704662e502a3a15cac5c5f8e693b0 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSF-2.0"
5SECTION = "devel/python"
6
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://reformat_sysconfig.py \
16 file://cgi_py.patch \
17 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
19 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
20 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
21 file://crosspythonpath.patch \
22 file://0001-test_locale.py-correct-the-test-output-format.patch \
23 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
24 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
25 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
26 file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \
27 file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \
28 file://makerace.patch \
29 file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \
30 file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \
31 file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \
32 file://deterministic_imports.patch \
33 file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050034 file://0001-Update-test_sysconfig-for-posix_user-purelib.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060035 "
36
37SRC_URI:append:class-native = " \
38 file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \
39 file://12-distutils-prefix-is-inside-staging-area.patch \
40 file://0001-Don-t-search-system-for-headers-libraries.patch \
41 "
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060042SRC_URI[sha256sum] = "29e4b8f5f1658542a8c13e2dd277358c9c48f2b2f7318652ef1675e402b9d2af"
Andrew Geissler517393d2023-01-13 08:55:19 -060043
44# exclude pre-releases for both python 2.x and 3.x
45UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
46UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
47
48CVE_PRODUCT = "python"
49
50# Upstream consider this expected behaviour
51CVE_CHECK_IGNORE += "CVE-2007-4559"
52# This is not exploitable when glibc has CVE-2016-10739 fixed.
53CVE_CHECK_IGNORE += "CVE-2019-18348"
54# These are specific to Microsoft Windows
55CVE_CHECK_IGNORE += "CVE-2020-15523 CVE-2022-26488"
56# The mailcap module is insecure by design, so this can't be fixed in a meaningful way.
57# The module will be removed in the future and flaws documented.
58CVE_CHECK_IGNORE += "CVE-2015-20107"
59
60PYTHON_MAJMIN = "3.11"
61
62S = "${WORKDIR}/Python-${PV}"
63
64BBCLASSEXTEND = "native nativesdk"
65
66inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
67
68MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
69
70ALTERNATIVE:${PN}-dev = "python3-config"
71ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
72ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
73
74
75DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses"
76DEPENDS:append:class-target = " python3-native"
77DEPENDS:append:class-nativesdk = " python3-native"
78
79EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
80EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"
81EXTRA_OECONF:append:class-target = " --with-build-python=nativepython3"
82EXTRA_OECONF:append:class-nativesdk = " --with-build-python=nativepython3"
83
84export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
85
86EXTRANATIVEPATH += "python3-native"
87
88# LTO will be enabled via packageconfig depending upong distro features
89LTO:class-target = ""
90
91CACHED_CONFIGUREVARS = " \
92 ac_cv_file__dev_ptmx=yes \
93 ac_cv_file__dev_ptc=no \
94 ac_cv_working_tzset=yes \
95"
96
97# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
98PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
99PACKAGECONFIG:class-native ??= "readline gdbm"
100PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
101PACKAGECONFIG[readline] = ",,readline"
102PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
103# Use profile guided optimisation by running PyBench inside qemu-user
104PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
105PACKAGECONFIG[tk] = ",,tk"
106PACKAGECONFIG[tcl] = ",,tcl"
107PACKAGECONFIG[gdbm] = ",,gdbm"
108PACKAGECONFIG[lto] = "--with-lto,,"
109
110do_configure:prepend () {
111 mkdir -p ${B}/Modules
112 cat > ${B}/Modules/Setup.local << EOF
113*disabled*
114${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
115${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
116EOF
117}
118
119CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
120
121EXTRA_OEMAKE = '\
122 STAGING_LIBDIR=${STAGING_LIBDIR} \
123 STAGING_INCDIR=${STAGING_INCDIR} \
124 LIB=${baselib} \
125'
126
127do_compile:prepend:class-target() {
128 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
129 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
130 cat >pgo-wrapper <<EOF
131#!/bin/sh
132cd ${B}
133$qemu_binary "\$@"
134EOF
135 chmod +x pgo-wrapper
136 fi
137}
138
139do_install:prepend() {
140 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
141}
142
143do_install:append:class-target() {
144 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
145}
146
147do_install:append:class-native() {
148 # Make sure we use /usr/bin/env python
149 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
150 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
151 done
152 # Add a symlink to the native Python so that scripts can just invoke
153 # "nativepython" and get the right one without needing absolute paths
154 # (these often end up too long for the #! parser in the kernel as the
155 # buffer is 128 bytes long).
156 ln -s python3-native/python3 ${D}${bindir}/nativepython3
157
158 # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them
159 # and the overhead in each recipe-sysroot-native isn't worth it, particularly
160 # when they're only used for python called with -O or -OO.
161 #find ${D} -name *opt-*.pyc -delete
162 # Remove all pyc files. There are a ton of them and it is probably faster to let
163 # python create the ones it wants at runtime rather than manage in the sstate
164 # tarballs and sysroot creation.
165 find ${D} -name *.pyc -delete
166
167 # Nothing should be looking into ${B} for python3-native
168 sed -i -e 's:${B}:/build/path/unavailable/:g' \
169 ${D}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile
170
171 # disable the lookup in user's site-packages globally
172 sed -i 's#ENABLE_USER_SITE = None#ENABLE_USER_SITE = False#' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
173
174 # python3-config needs to be in /usr/bin and not in a subdir of it to work properly
175 mv ${D}/${bindir}/${PN}/python*config ${D}/${bindir}/
176}
177
178do_install:append() {
179 for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
180 python3 ${WORKDIR}/reformat_sysconfig.py $c
181 done
182 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython*
183
184 mkdir -p ${D}${libdir}/python-sysconfigdata
185 sysconfigfile=`find ${D} -name _sysconfig*.py`
186 sed -i \
187 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
188 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
189 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
190 -e "s,^ 'INCLUDEPY'.*, 'INCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
191 -e "s,^ 'CONFINCLUDEPY'.*, 'CONFINCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
192 -e "s,${B},/build/path/unavailable/,g" \
193 $sysconfigfile
194 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
195
196
197 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
198 # being written without strict ordering, even with PYTHONHASHSEED = 0
199 # Upstream is discussing ways to solve the issue properly, until then let's
200 # just not install the problematic files.
201 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
202 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
203 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
204
205 # Similar to the above, we're getting reproducibility issues with
206 # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
207 # so remove it too
208 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
209
210 # Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
211 # style targets as they're only used when python is called with the -O or -OO options
212 # which is rare.
213 find ${D} -name *opt-*.pyc -delete
214}
215
216do_install:append:class-nativesdk () {
217 # Make sure we use /usr/bin/env python
218 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
219 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
220 done
221 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
222}
223
224SYSROOT_PREPROCESS_FUNCS:append:class-target = " provide_target_config_script"
225SYSROOT_PREPROCESS_FUNCS:append:class-nativesdk = " provide_target_config_script"
226
227# This is installed into /usr/python-target-config/ and not /usr/bin
228# because adding target sysroot's /usr/bin/ to PATH has unwanted side effects
229# in components erroneously picking up other target executables from it
230provide_target_config_script() {
231 install -d ${SYSROOT_DESTDIR}${prefix}/python-target-config/
232 install ${D}/${bindir}/python3-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
233 install ${D}/${bindir}/python${PYTHON_MAJMIN}-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
234}
235SYSROOT_DIRS += "${prefix}/python-target-config/"
236
237SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
238SSTATE_HASHEQUIV_FILEMAP = " \
239 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \
240 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \
241 populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \
242 populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \
243 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \
244 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \
245 "
246PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
247
248py_package_preprocess () {
249 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
250 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
251 -e 's|${DEBUG_PREFIX_MAP}||g' \
252 -e 's:${HOSTTOOLS_DIR}/::g' \
253 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
254 -e 's:${RECIPE_SYSROOT}::g' \
255 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
256 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
257 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
258 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
259
260 # Reformat _sysconfigdata after modifying it so that it remains
261 # reproducible
262 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
263 python3 ${WORKDIR}/reformat_sysconfig.py $c
264 done
265
266 # Recompile _sysconfigdata after modifying it
267 cd ${PKGD}
268 sysconfigfile=`find . -name _sysconfigdata_*.py`
269 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
270 -c "from py_compile import compile; compile('$sysconfigfile')"
271 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
272 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
273 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
274 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
275 cd -
276
277 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
278
279 #Remove the unneeded copy of target sysconfig data
280 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
281}
282
283# We want bytecode precompiled .py files (.pyc's) by default
284# but the user may set it on their own conf
285INCLUDE_PYCS ?= "1"
286
287python(){
288 import collections, json
289
290 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
291 # This python changes the datastore based on the contents of a file, so mark
292 # that dependency.
293 bb.parse.mark_dependency(d, filename)
294
295 with open(filename) as manifest_file:
296 manifest_str = manifest_file.read()
297 json_start = manifest_str.find('# EOC') + 6
298 manifest_file.seek(json_start)
299 manifest_str = manifest_file.read()
300 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
301
302 # First set RPROVIDES for -native case
303 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
304 pn = 'python3'
305 rprovides = (d.getVar('RPROVIDES') or "").split()
306
307 # ${PN}-misc-native is not in the manifest
308 rprovides.append(pn + '-misc-native')
309
310 for key in python_manifest:
311 pypackage = pn + '-' + key + '-native'
312 if pypackage not in rprovides:
313 rprovides.append(pypackage)
314
315 d.setVar('RPROVIDES:class-native', ' '.join(rprovides))
316
317 # Then work on the target
318 include_pycs = d.getVar('INCLUDE_PYCS')
319
320 packages = d.getVar('PACKAGES').split()
321 pn = d.getVar('PN')
322
323 newpackages=[]
324 for key in python_manifest:
325 pypackage = pn + '-' + key
326
327 if pypackage not in packages:
328 # We need to prepend, otherwise python-misc gets everything
329 # so we use a new variable
330 newpackages.append(pypackage)
331
332 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
333 d.setVar('FILES:' + pypackage, '')
334 for value in python_manifest[key]['files']:
335 d.appendVar('FILES:' + pypackage, ' ' + value)
336
337 # Add cached files
338 if include_pycs == '1':
339 for value in python_manifest[key]['cached']:
340 d.appendVar('FILES:' + pypackage, ' ' + value)
341
342 for value in python_manifest[key]['rdepends']:
343 # Make it work with or without $PN
344 if '${PN}' in value:
345 value=value.split('-', 1)[1]
346 d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value)
347
348 for value in python_manifest[key].get('rrecommends', ()):
349 if '${PN}' in value:
350 value=value.split('-', 1)[1]
351 d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value)
352
353 d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary'])
354
355 # Prepending so to avoid python-misc getting everything
356 packages = newpackages + packages
357 d.setVar('PACKAGES', ' '.join(packages))
358 d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
359 d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
360
361 if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
362 bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
363}
364
365# Files needed to create a new manifest
366
367do_create_manifest() {
368 # This task should be run with every new release of Python.
369 # We must ensure that PACKAGECONFIG enables everything when creating
370 # a new manifest, this is to base our new manifest on a complete
371 # native python build, containing all dependencies, otherwise the task
372 # wont be able to find the required files.
373 # e.g. BerkeleyDB is an optional build dependency so it may or may not
374 # be present, we must ensure it is.
375
376 cd ${WORKDIR}
377 # This needs to be executed by python-native and NOT by HOST's python
378 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
379 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
380}
381
382# bitbake python -c create_manifest
383# Make sure we have native python ready when we create a new manifest
384addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
385
386# manual dependency additions
387RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules"
388RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
389RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
390
391# For historical reasons PN is empty and provided by python3-modules
392FILES:${PN} = ""
393RPROVIDES:${PN}-modules = "${PN}"
394
395FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
396FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
397
398# provide python-pyvenv from python3-venv
399RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv"
400
401# package libpython3
402PACKAGES =+ "libpython3 libpython3-staticdev"
403FILES:libpython3 = "${libdir}/libpython*.so.*"
404FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
405INSANE_SKIP:${PN}-dev += "dev-elf"
406INSANE_SKIP:${PN}-ptest = "dev-deps"
407
408# catch all the rest (unsorted)
409PACKAGES += "${PN}-misc"
410RDEPENDS:${PN}-misc += "\
411 ${PN}-core \
412 ${PN}-email \
413 ${PN}-codecs \
414 ${PN}-pydoc \
415 ${PN}-pickle \
416 ${PN}-audio \
417 ${PN}-numbers \
418"
419RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
420RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500421RDEPENDS:${PN}-modules:append:class-target = " ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '${MLPREFIX}python3-gdbm', '', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -0600422FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
423
424# catch manpage
425PACKAGES += "${PN}-man"
426FILES:${PN}-man = "${datadir}/man"
427
428# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
429RDEPENDS:libpython3:append:libc-glibc = " libgcc"
430RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500431RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev unzip bzip2 libgcc tzdata coreutils sed"
432RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-fr-fr locale-base-en-us locale-base-tr-tr locale-base-de-de"
Andrew Geissler517393d2023-01-13 08:55:19 -0600433RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
434RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"
435DEV_PKG_DEPENDENCY = ""
436RDEPENDS:${PN}-pydoc += "${PN}-io"
437
438RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash"
439RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash"
440
441# Python's tests contain large numbers of files we don't need in the recipe sysroots
442SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
443py3_sysroot_cleanup () {
444 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
445}