blob: b3d7b229c89ee9ce564661a3917b0a9c1819fd46 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "WPE's backend based on a freedesktop.org stack."
2HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo"
3BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66"
7DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy"
8
9DEPENDS:append:class-target = " wayland-native"
10
11inherit meson features_check pkgconfig
12
13REQUIRED_DISTRO_FEATURES = "opengl"
14
15SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016SRC_URI[sha256sum] = "93c9766ae9864eeaeaee2b0a74f22cbca08df42c1a1bdb55b086f2528e380d38"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18# Especially helps compiling with clang which enable this as error when
19# using c++11
20CXXFLAGS += "-Wno-c++11-narrowing"
21
22# This is a tweak of upstream-version-is-even needed because
23# ipstream directory contains tarballs for other components as well.
24UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"