blob: c9aa25c518e2607f7b79057432d3e6ab860387f1 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
Patrick Williams520786c2023-06-25 16:20:36 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=74b6f2f7818a4e3a80d03556f71b129b \
7 file://LICENSE-extra;md5=f9307417749e19bd1d6d68a394b49324"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Andrew Geissler8f840682023-07-21 09:09:43 -05009SRCREV = "f0bb7e40f0508bedf6fad33769b3f87bb8aedfa6"
10SRC_URI = "git://github.com/libuv/libuv.git;branch=v1.x;protocol=https"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13S = "${WORKDIR}/git"
14
15inherit autotools
16
17do_configure() {
18 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
19 oe_runconf
20}
21
22BBCLASSEXTEND = "native"