Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 1 | # SPDX-License-Identifier: MIT |
| 2 | # Copyright (C) 2023 iris-GmbH infrared & intelligent sensors |
| 3 | |
| 4 | SUMMARY = "Automate and standardize testing in Python. It is part of a larger vision of easing the packaging, testing and release process of Python software (alongside pytest and devpi)." |
| 5 | HOMEPAGE = "http://tox.readthedocs.org/" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "9e2c5091a117d03b583c57c4c40aecd068099c17d40520e7b165e85c19334534" |
| 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | inherit pypi python_hatchling |
| 13 | |
| 14 | DEPENDS += "\ |
| 15 | ${PYTHON_PN}-hatch-vcs-native \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN} += "\ |
| 19 | ${PYTHON_PN}-cachetools \ |
| 20 | ${PYTHON_PN}-chardet \ |
| 21 | ${PYTHON_PN}-colorama \ |
| 22 | ${PYTHON_PN}-filelock \ |
| 23 | ${PYTHON_PN}-packaging \ |
| 24 | ${PYTHON_PN}-platformdirs \ |
| 25 | ${PYTHON_PN}-pluggy \ |
| 26 | ${PYTHON_PN}-pyproject-api \ |
| 27 | ${PYTHON_PN}-tomli \ |
| 28 | ${PYTHON_PN}-virtualenv \ |
| 29 | " |
| 30 | |
| 31 | # Install all built-in python3 modules, as the software tested with tox might |
| 32 | # depend on it. Tox will attempt to install all required dependencies |
| 33 | # in a virtualenv using pip, but this obviously does not include the built-in modules. |
| 34 | RDEPENDS:${PN} += "${PYTHON_PN}-modules" |