blob: 74cf933b725f26b5deea944cfabafd4e2d082993 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require core-image-minimal.bb
5require conf/distro/include/ptest-packagelists.inc
6
7DESCRIPTION += "Also including the ${MCNAME} ptest package."
8HOMEPAGE = "https://www.yoctoproject.org/"
9
10PTESTS = "${PTESTS_SLOW} ${PTESTS_FAST}"
11
12IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"
13
14BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS').split()])}"
15
16# The image can sufficiently large (~1.8GB) that we need to be careful that it fits in a live
17# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
18# box) and explicitly add up to 1500MB.
19# strace-ptest in particular needs more than 500MB
20IMAGE_OVERHEAD_FACTOR = "1.0"
21IMAGE_ROOTFS_EXTRA_SPACE = "324288"
Andrew Geissler8f840682023-07-21 09:09:43 -050022IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-mdadm = "1524288"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050023IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-strace = "1024288"
24IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-lttng-tools = "1524288"
25
26# ptests need more memory than standard to avoid the OOM killer
27QB_MEM = "-m 1024"
28QB_MEM:virtclass-mcextend-lttng-tools = "-m 4096"
Andrew Geissler8f840682023-07-21 09:09:43 -050029QB_MEM:virtclass-mcextend-python3 = "-m 2048"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050030QB_MEM:virtclass-mcextend-python3-cryptography = "-m 4096"
31
32TEST_SUITES = "ping ssh parselogs ptest"
33
34# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
35PTEST_EXPECT_FAILURE = "1"
36
37python () {
38 if not d.getVar("MCNAME"):
39 raise bb.parse.SkipRecipe("No class extension set")
40}
41