blob: e3a0169566c8dbc4aa2b10a019a72c9a21b0b3cc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "mbedtls is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://tls.mbed.org/"
19
20LICENSE = "Apache-2.0"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060021LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23SECTION = "libs"
24
Andrew Geissler8fc454f2020-12-11 16:27:59 -060025S = "${WORKDIR}/git"
26SRCREV = "523f0554b6cdc7ace5d360885c3f5bbcc73ec0e8"
27SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development \
28 file://fix-incorrect-EOF-check-in-ssl_context_info.patch \
29"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
31inherit cmake
32
33PACKAGECONFIG ??= "shared-libs programs"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060034PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
36
37EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}"
38
39PROVIDES += "polarssl"
40RPROVIDES_${PN} = "polarssl"
41
42PACKAGES =+ "${PN}-programs"
43FILES_${PN}-programs = "${bindir}/"
44
45BBCLASSEXTEND = "native nativesdk"