blob: f514c0b782a9027a028d40381c7e34eb8a874c4f [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001require ${BPN}.inc
2
Brad Bishop8410d612019-11-25 09:40:59 -05003inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
Brad Bishop868407c2019-11-04 13:24:47 -05004
5# polkit and gobject-introspection are mandatory and cannot be configured
6REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
7UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
8
9DEPENDS += " \
10 ${BPN}-native \
11 glib-2.0 \
12 lcms \
13 sqlite3 \
14 libgusb \
15 libgudev \
16 polkit \
17"
18
19SRC_URI += " \
20 file://0001-Run-native-cd_idt8-cd_create_profile.patch \
21"
22
23EXTRA_OEMESON = " \
24 -Dman=false \
25 -Ddocs=false \
26"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
29PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
30
31SYSTEMD_SERVICE_${PN} = "colord.service"
32
33FILES_${PN} += " \
34 ${datadir}/dbus-1 \
35 ${datadir}/polkit-1 \
36 ${datadir}/glib-2.0 \
37 ${datadir}/color \
38 ${systemd_user_unitdir} \
Andrew Geissler8fc454f2020-12-11 16:27:59 -060039 ${nonarch_libdir}/tmpfiles.d \
Brad Bishop868407c2019-11-04 13:24:47 -050040 ${libdir}/colord-plugins \
41 ${libdir}/colord-sensors \
42"
43
44USERADD_PACKAGES = "${PN}"
45USERADD_PARAM_${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"