blob: e1cb2ac7157559b01e942855af9a1d81918bb7ab [file] [log] [blame]
George Hung39090132020-05-12 16:56:27 +08001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
Brandon Kim1e427092021-08-10 15:46:03 -070010RDEPENDS:${PN} += "bash"
11RDEPENDS:${PN} += "libgpiod-tools"
George Hung39090132020-05-12 16:56:27 +080012
Brandon Kimc7f50e72020-08-12 19:15:12 -070013SRC_URI = " file://hotswap-power-cycle.service \
14 file://tray_powercycle.sh \
15 "
George Hung39090132020-05-12 16:56:27 +080016
17do_install() {
18 install -d ${D}${systemd_system_unitdir}
19 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir}
Brandon Kimc7f50e72020-08-12 19:15:12 -070020
21 install -d ${D}${bindir}
22 install -m 0755 ${WORKDIR}/tray_powercycle.sh ${D}${bindir}
George Hung39090132020-05-12 16:56:27 +080023}
24
25SYSTEMD_PACKAGES = "${PN}"
Brandon Kim1e427092021-08-10 15:46:03 -070026SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service"
George Hung39090132020-05-12 16:56:27 +080027