blob: 7d3a339978875f8291d436c0cd0f1fd226b7ae3a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Embedded Linux Library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://01.org/ell"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
4low-level functionality for system daemons. It typically has no \
5dependencies other than the Linux kernel, C standard library, and \
6libdl (for dynamic linking). While ELL is designed to be efficient \
7and compact enough for use on embedded Linux platforms, it is not \
8limited to resource-constrained systems."
9SECTION = "libs"
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
12
13DEPENDS = "dbus"
14
15inherit autotools pkgconfig
16
Andrew Geisslerd1e89492021-02-12 15:35:20 -060017SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
18 file://0001-pem.c-do-not-use-rawmemchr.patch \
19 "
Andrew Geissler90fd73c2021-03-05 15:25:55 -060020SRC_URI[sha256sum] = "c1b7ae5676eec310f08757b3d8652b8e818776be1897fb5deb59e55f02a012a7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22do_configure_prepend () {
23 mkdir -p ${S}/build-aux
24}