blob: 549b0cbdf77a5a43b3e533afff414e24830b1a3e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very simple session manager for X"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Simple session manager for X, that provides just the right boilerplate to create a session and launch the browser "
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003HOMEPAGE = "http://www.yoctoproject.org"
4BUGTRACKER = "http://bugzilla.pokylinux.org"
5
6PR = "r4"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://mini-x-session;endline=5;md5=b6430bffbcf05f9760e72938826b7487"
10
11SECTION = "x11"
12RCONFLICTS_${PN} = "matchbox-common"
13
14SRC_URI = "file://mini-x-session"
15S = "${WORKDIR}"
16
17RDEPENDS_${PN} = "sudo"
18
19inherit update-alternatives
20
21ALTERNATIVE_${PN} = "x-session-manager"
22ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/mini-x-session"
23ALTERNATIVE_PRIORITY = "50"
24
25do_install() {
26 install -d ${D}/${bindir}
27 install -m 0755 ${S}/mini-x-session ${D}/${bindir}
28}