blob: abc216f434e1631cc10d1b70359160d9df5da109 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
5HOMEPAGE = "https://releases.pagure.org/liberation-fonts/"
6BUGTRACKER = "https://bugzilla.redhat.com/"
7
8SECTION = "x11/fonts"
9LICENSE = "OFL-1.1"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b"
11PE = "1"
12
Andrew Geissler90fd73c2021-03-05 15:25:55 -060013# remove at next version upgrade or when output changes
14PR = "r1"
15HASHEQUIV_HASH_VERSION .= ".2"
16
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017inherit allarch fontcache
18
19FONT_PACKAGES = "${PN}"
20
21SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
22 file://30-liberation-aliases.conf"
23
24S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
25
26SRC_URI[md5sum] = "5c781723a0d9ed6188960defba8e91cf"
27SRC_URI[sha256sum] = "7890278a6cd17873c57d9cd785c2d230d9abdea837e96516019c5885dd271504"
28
29do_install () {
30 install -d ${D}${datadir}/fonts/ttf/
31 for i in *.ttf; do
32 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
33 done
34
35 install -d ${D}${sysconfdir}/fonts/conf.d/
36 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
37
38 install -d ${D}${prefix}/share/doc/${BPN}/
39 install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/
40}
41
42PACKAGES = "${PN}"
43FILES_${PN} += "${sysconfdir} ${datadir}"
Brad Bishop19323692019-04-05 15:28:33 -040044
45BBCLASSEXTEND = "native nativesdk"