blob: baaf8fa9ad1cc9f82c341d6abd75c089a3aede66 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Touchscreen calibration data from xinput-calibrator"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A generic touchscreen calibration program for X.Org"
3HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xinput_calibrator/"
4BUGTRACKER = "https://github.com/tias/xinput_calibrator/issues"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8PR = "r7"
9
10SRC_URI = "file://pointercal.xinput"
11S = "${WORKDIR}"
12
13do_install() {
14 # Only install file if it has a contents
15 if [ -s ${S}/pointercal.xinput ] &&\
16 [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
17 install -d ${D}${sysconfdir}/
18 install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
19 fi
20}
21
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"