blob: 90b6fc38df720657fe0359f6df334169932f0629 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Python bindings for GStreamer 1.0"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060011SRC_URI[sha256sum] = "4e630735276e08ff4d70337aa5d91fd008e5f1ed3dc0993674cd5820e264259a"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS_${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
Andrew Geissler90fd73c2021-03-05 15:25:55 -060020EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
21
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
24UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
25
26inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check