blob: 164831be39ce518d500ff4cca2239ce242eeecba [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "General-purpose library specifically developed for the WPE-flavored port of WebKit."
2HOMEPAGE = "https://github.com/WebPlatformForEmbedded/libwpe"
3BUGTRACKER = "https://github.com/WebPlatformForEmbedded/libwpe/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
7DEPENDS = "virtual/egl libxkbcommon"
8
9# Workaround build issue with RPi userland EGL libraries.
10CFLAGS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"
11
12inherit cmake features_check
13
14REQUIRED_DISTRO_FEATURES = "opengl"
15
16SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017SRC_URI[sha256sum] = "a6f00a7d091cbd4db57fe7ee3b4c12c6350921d654ed79812800a26c888481d2"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060018
19# This is a tweak of upstream-version-is-even needed because
20# ipstream directory contains tarballs for other components as well.
21UPSTREAM_CHECK_REGEX = "libwpe-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"