blob: ed87f11a8a240a8399700de5483627dfe20a1a5a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Enchant Spell checker API Library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A library (and command-line program) that wraps a number of \
3different spelling libraries and programs with a consistent interface."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004SECTION = "libs"
5HOMEPAGE = "https://abiword.github.io/enchant/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006BUGTRACKER = "https://github.com/AbiWord/enchant/issues/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LICENSE = "LGPLv2.1+"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06008LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10DEPENDS = "glib-2.0"
11
12inherit autotools pkgconfig
13
14SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060015SRC_URI[sha256sum] = "3b0f2215578115f28e2a6aa549b35128600394304bd79d6f28b0d3b3d6f46c03"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
18
19S = "${WORKDIR}/enchant-${PV}"
20
21EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
22
23PACKAGECONFIG ??= "aspell"
24PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
25PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
26
27FILES_${PN} += " \
28 ${datadir}/enchant-2 \
29 ${libdir}/enchant-2 \
30"
31FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"