blob: cd2617b130e891be858f3e7ffab91b0021bcf787 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Key/value database library with extensible hashing"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library of database functions that use extensible hashing \
3and work similar to the standard UNIX dbm. These routines are provided \
4to a programmer needing to create and manipulate a hashed database."
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "http://www.gnu.org/software/gdbm/"
6SECTION = "libs"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
9
10
11SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
12 file://run-ptest \
13 file://ptest.patch \
14 "
15
Andrew Geisslerd1e89492021-02-12 15:35:20 -060016SRC_URI[md5sum] = "aeb29c6a90350a4c959cd1df38cd0a7e"
17SRC_URI[sha256sum] = "37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc"
Brad Bishop19323692019-04-05 15:28:33 -040018
19inherit autotools gettext texinfo lib_package ptest
20
21# Needed for dbm python module
Andrew Geissler82c905d2020-04-13 13:39:40 -050022EXTRA_OECONF = "--enable-libgdbm-compat --without-readline"
Brad Bishop19323692019-04-05 15:28:33 -040023
24# Stop presence of dbm/nbdm on the host contaminating builds
25CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
26
27BBCLASSEXTEND = "native nativesdk"
28
Brad Bishop19323692019-04-05 15:28:33 -040029do_install_append () {
30 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
31 # these headers
32 install -d ${D}${includedir}/gdbm
33 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
34 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
35}
36
37RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
38
39do_compile_ptest() {
40 oe_runmake -C tests buildtests
41}
42
43PACKAGES =+ "${PN}-compat \
44 "
45FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
46 "