blob: 1181c8341bf9a86fca303aff96d9c8cc80daa727 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A complete and free implementation of the OpenPGP standard \
3as defined by RFC4880 (also known as PGP). GnuPG allows you to encrypt \
4and sign your data and communications; it features a versatile key \
5management system, along with access modules for all kinds of public \
6key directories."
Andrew Geissler82c905d2020-04-13 13:39:40 -05007HOMEPAGE = "http://www.gnupg.org/"
8LICENSE = "GPLv3 & LGPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
10 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
11
12DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
13
14inherit autotools gettext texinfo pkgconfig
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
18 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
19 file://0002-use-pkgconfig-instead-of-npth-config.patch \
20 file://0003-dirmngr-uses-libgpg-error.patch \
21 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
22 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
23 "
24SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
25 file://relocate.patch"
26SRC_URI_append_class-nativesdk = " file://relocate.patch"
27
Andrew Geisslerd1e89492021-02-12 15:35:20 -060028SRC_URI[sha256sum] = "34e60009014ea16402069136e0a5f63d9b65f90096244975db5cea74b3d02399"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30EXTRA_OECONF = "--disable-ldap \
31 --disable-ccid-driver \
32 --with-zlib=${STAGING_LIBDIR}/.. \
33 --with-bzip2=${STAGING_LIBDIR}/.. \
34 --with-readline=${STAGING_LIBDIR}/.. \
35 --enable-gpg-is-gpg2 \
36 "
37
38# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
39PACKAGES =+ "${PN}-gpg"
40FILES_${PN}-gpg = " \
41 ${bindir}/gpg \
42 ${bindir}/gpg2 \
43 ${bindir}/gpg-agent \
44"
45
46# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
47# to ensure all tools are included. This is done only in non-native
48# builds. Native builds don't have sub-packages, so appending RDEPENDS
49# in this case breaks recipe parsing.
50RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
51
52RRECOMMENDS_${PN} = "pinentry"
53
54do_configure_prepend () {
55 # Else these could be used in prefernce to those in aclocal-copy
56 rm -f ${S}/m4/gpg-error.m4
57 rm -f ${S}/m4/libassuan.m4
58 rm -f ${S}/m4/ksba.m4
59 rm -f ${S}/m4/libgcrypt.m4
60}
61
62do_install_append() {
63 ln -sf gpg2 ${D}${bindir}/gpg
64 ln -sf gpgv2 ${D}${bindir}/gpgv
65}
66
67do_install_append_class-native() {
68 create_wrappers ${STAGING_BINDIR_NATIVE}
69}
70
71do_install_append_class-nativesdk() {
72 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
73}
74
75create_wrappers() {
76 for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
77 create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
78 done
79}
80
81PACKAGECONFIG ??= "gnutls"
82PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
83PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
84
85BBCLASSEXTEND = "native nativesdk"