blob: a0119729d8e6558837e93657d5efe773bc57cdb1 [file] [log] [blame]
Andrew Geissler475cb722020-07-10 16:00:51 -05001SUMMARY = "Small library that defines common error values for all GnuPG components"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Contains common error codes and error handling functions used by GnuPG, Libgcrypt, GPGME and more packages. "
Andrew Geissler475cb722020-07-10 16:00:51 -05003HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
8 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
10 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
11 "
12
13
14SECTION = "libs"
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
18 file://pkgconfig.patch \
19 file://0001-Do-not-fail-when-testing-config-scripts.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050020 "
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022SRC_URI[sha256sum] = "64b078b45ac3c3003d7e352a5e05318880a5778c42331ce1ef33d1a0d9922742"
Andrew Geissler475cb722020-07-10 16:00:51 -050023
24BINCONFIG = "${bindir}/gpg-error-config"
25
26inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
27
28MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
29
30CPPFLAGS += "-P"
31
32do_install_append() {
33 # we don't have common lisp in OE
34 rm -rf "${D}${datadir}/common-lisp/"
35 oe_multilib_header gpg-error.h gpgrt.h
36}
37
38FILES_${PN}-dev += "${bindir}/gpg-error"
39FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
40
41BBCLASSEXTEND = "native nativesdk"