blob: dc917fa1666616cadd820dc5542f4d15d6157360 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "High-Performance Asynchronous HTTP Client Library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "The Apache Serf library is a C-based HTTP client library built upon the Apache \
3Portable Runtime (APR) library. It multiplexes connections, running the \
4read/write communication asynchronously. Memory copies and transformations are \
5kept to a minimum to provide high performance operation."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
7 file://norpath.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +08008 file://env.patch \
9 file://0001-Fix-syntax-of-a-print-in-the-scons-file-to-unbreak-b.patch \
10 file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \
11 file://0003-gen_def.patch \
12 file://0004-Follow-up-to-r1811083-fix-building-with-scons-3.0.0-.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040013 file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080014 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16SRC_URI[md5sum] = "370a6340ff20366ab088012cd13f2b57"
17SRC_URI[sha256sum] = "549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf7a87cc"
18
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
21
Brad Bishop15ae2502019-06-18 21:44:24 -040022inherit scons
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
Brad Bishop15ae2502019-06-18 21:44:24 -040024DEPENDS += " openssl apr apr-util util-linux expat"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
Brad Bishop15ae2502019-06-18 21:44:24 -040026EXTRA_OESCONS = " \
27 LIBDIR=${libdir} \
28 --install-sandbox=${D} \
29 CC="${CC}" \
30 CFLAGS="${CFLAGS}" \
31 LINKFLAGS="${LDFLAGS}" \
32 APR=`which apr-1-config` \
33 APU=`which apu-1-config` \
34 OPENSSL="${STAGING_EXECPREFIXDIR}" \
35 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
Andrew Geissler09209ee2020-12-13 08:44:15 -060037# scons creates non-reproducible archives
38do_install_append() {
39 rm ${D}/${libdir}/*.a
40}
41
Andrew Geisslerb7d28612020-07-24 16:15:54 -050042BBCLASSEXTEND = "native nativesdk"