blob: 165bccadc1f424caccc638c4b66485f662c2a34d [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Platform-independent library (tested on Windows/Linux) for reading and writing metadata in media files, including video, audio, and photo formats. This is a convenient one-stop-shop to present or tag all your media collection, regardless of which format/container these might use. You can read/write the standard or more common tags/properties of a media, or you can also create and retrieve your own custom tags."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003SECTION = "libs/multimedia"
4HOMEPAGE = "http://taglib.github.io/"
Brad Bishop15ae2502019-06-18 21:44:24 -04005LICENSE = "LGPLv2.1 | MPL-1.1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
7 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
8 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
9
10DEPENDS = "zlib"
11
12SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz \
13 file://CVE-2017-12678.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080014 file://CVE-2018-11439.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015 "
16
17SRC_URI[md5sum] = "cee7be0ccfc892fa433d6c837df9522a"
18SRC_URI[sha256sum] = "b6d1a5a610aae6ff39d93de5efd0fdc787aa9e9dc1e7026fa4c961b26563526b"
19
20UPSTREAM_CHECK_URI = "http://github.com/taglib/taglib/releases/"
21
22BINCONFIG = "${bindir}/taglib-config"
23
24inherit cmake pkgconfig binconfig-disabled
25
26PACKAGES =+ "${PN}-c"
27FILES_${PN}-c = "${libdir}/libtag_c.so.*"
28
29EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
30 -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
31 -DHAVE_BOOST_BYTESWAP=FALSE \
32 -DCMAKE_CXX_STANDARD=11 \
33 -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
34 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
35"
36CXXFLAGS += "-std=c++11"
37
38do_configure_prepend () {
39 rm -f ${S}/admin/ltmain.sh
40 rm -f ${S}/admin/libtool.m4.in
41}
42
43# without -fPIC depending packages failed with many error like:
44# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
45CXXFLAGS += "-fPIC"