blob: dda99e74c1a696c809eec9c71a1c85fd6421dd24 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001SUMMARY = "Board Firmware binaries for N1SDP"
2SECTION = "firmware"
3
4LICENSE = "STM-SLA0044-Rev5"
5LIC_FILES_CHKSUM = "file://LICENSES/STM.TXT;md5=cd18335eff80d0a690a650f0e6748baf"
6
7inherit deploy
8
9INHIBIT_DEFAULT_DEPS = "1"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12COMPATIBLE_MACHINE = "n1sdp"
13
14SRC_URI = "git://git.gitlab.arm.com/arm-reference-solutions/board-firmware.git;protocol=https;branch=n1sdp"
15
16SRCREV = "e6cd91c7a9733e501bc3b57ff6f9eb2461ffee54"
17
18S = "${WORKDIR}/git"
19
20INSTALL_DIR = "/n1sdp-board-firmware_source"
21
22do_install() {
23 rm -rf ${S}/SOFTWARE
24 install -d ${D}${INSTALL_DIR}
25 cp -Rp --no-preserve=ownership ${S}/* ${D}${INSTALL_DIR}
26}
27
28FILES:${PN} = "${INSTALL_DIR}"
29SYSROOT_DIRS += "${INSTALL_DIR}"
30
31do_deploy() {
32 install -d ${DEPLOYDIR}${INSTALL_DIR}
33 cp -Rp --no-preserve=ownership ${S}/* ${DEPLOYDIR}${INSTALL_DIR}
34}
35addtask deploy after do_install before do_build