blob: fbdfa965d4f7e569bffe3fb9acf92ddc52c17788 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001# Image class to write .fvpconf files for use with runfvp. If this is desired
2# then add fvpboot to IMAGE_CLASSES, and set the variables below in your machine
3# configuration as appropriate.
4
5# Name of recipe providing FVP executable. If unset then the executable must be installed on the host.
6FVP_PROVIDER ?= ""
7# Name of FVP executable to run
8FVP_EXE ?= ""
9# Flags for --parameter/-C
10FVP_CONFIG ?= ""
11# Flags for --data
12FVP_DATA ?= ""
13# Flags for --application
14FVP_APPLICATIONS ?= ""
15# Flags to name serial terminals. Flag name is the terminal id (such as
16# terminal_0), value is a human-readable name. If the name is not set
17# then runfvp will hide the terminal.
18FVP_TERMINALS ?= ""
19# What terminal should be considered the primary console
20FVP_CONSOLE ?= ""
21# Flags for console names, as they appear in the FVP output. Flag name is an
22# application-specific id for the console for use in test cases
23FVP_CONSOLES[default] ?= "${FVP_CONSOLE}"
24# Arbitrary extra arguments
25FVP_EXTRA_ARGS ?= ""
26
27EXTRA_IMAGEDEPENDS += "${FVP_PROVIDER}"
28
Patrick Williams92b42cb2022-09-03 06:53:57 -050029IMAGE_CLASSES += "image-artifact-names"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040030
31IMAGE_POSTPROCESS_COMMAND += "do_write_fvpboot_conf;"
32python do_write_fvpboot_conf() {
33 # Note that currently this JSON file is in development and the format may
34 # change at any point, so it should always be used with a matching runfvp.
35
36 import json, shlex
37
38 if not d.getVar("FVP_EXE"):
39 return
40
41 conffile = os.path.join(d.getVar("IMGDEPLOYDIR"), d.getVar("IMAGE_NAME") + ".fvpconf")
42 conffile_link = os.path.join(d.getVar("IMGDEPLOYDIR"), d.getVar("IMAGE_LINK_NAME") + ".fvpconf")
43
44 data = {}
45 provider = d.getVar("FVP_PROVIDER")
46 if provider:
47 data["provider"] = provider
48 data["fvp-bindir"] = os.path.join(d.getVar("COMPONENTS_DIR"),
49 d.getVar("BUILD_ARCH"),
50 provider,
51 "usr", "bin")
52
53 def getFlags(varname):
54 flags = d.getVarFlags(varname)
55 # For unexplained reasons, getVarFlags() returns None if there are no flags
56 if flags is None:
57 return {}
58 # For other reasons, you can't pass expand=True
59 return {key: d.expand(value) for key, value in flags.items()}
60
61 data["exe"] = d.getVar("FVP_EXE")
62 data["parameters"] = getFlags("FVP_CONFIG")
63 data["data"] = shlex.split(d.getVar("FVP_DATA") or "")
64 data["applications"] = getFlags("FVP_APPLICATIONS")
65 data["consoles"] = getFlags("FVP_CONSOLES")
66 data["terminals"] = getFlags("FVP_TERMINALS")
67 data["args"] = shlex.split(d.getVar("FVP_EXTRA_ARGS") or "")
68
69 os.makedirs(os.path.dirname(conffile), exist_ok=True)
70 with open(conffile, "wt") as f:
71 json.dump(data, f)
72
73 if conffile_link != conffile:
74 if os.path.lexists(conffile_link):
75 os.remove(conffile_link)
76 os.symlink(os.path.basename(conffile), conffile_link)
77}
78
79def fvpboot_vars(d):
80 vars = ['DEPLOY_DIR_IMAGE', 'IMAGE_NAME', 'IMAGE_LINK_NAME', 'COMPONENTS_DIR', 'BUILD_ARCH']
81 vars.extend((k for k in d.keys() if k.startswith('FVP_')))
82 return " ".join(vars)
83
84do_write_fvpboot_conf[vardeps] += "${@fvpboot_vars(d)}"